CVE-2024-12905: tar-fs Vulnerable to Link Following and Path Traversal via Extracting a Crafted tar File
Affects tar-fsSource GCVE Database
Public exploit available (Exploit-DB) · CVSS 7.5 High : upgrade to 1.16.4 as a priority.
Data as of 30 Oct 2026, 02:29 UTC
Thin evidence
One scorer or none| CNA (seal) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 1.16.4, 2.1.2, 3.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 27 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by Seal Security
, 94 days before disclosure
CVE published
on cve.org
, t = 0
First Exploit-DB entry (opens in a new tab)
tar-fs 3.0.0 - Arbitrary File Write/Overwrite
, 26 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade tar-fs to 1.16.4; tar-fs to 2.1.2; tar-fs to 3.0.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmtar-fs | Affected
| Fixed in
|
| npmtar-fs | Affected
| Fixed in
|
| npmtar-fs | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions 1.16.4, 2.1.2, and 3.0.7 of tar-fs have been released and should be applied to remediate this vulnerability. Users should upgrade to these versions or later to prevent exploitation. No additional mitigations are specified by the vendor advisory.
Description
The tar-fs package contains a vulnerability (CVE-2024-12905) involving improper link resolution and path traversal during extraction of crafted tar files. This flaw allows an attacker to write or overwrite files outside the intended extraction directory, potentially leading to unauthorized file modifications. The issue affects multiple versions of tar-fs prior to fixed releases 1.16.4, 2.1.2, and 3.0.7.
References
- nvd.nist.gov/vuln/detail/CVE-2024-12905 (opens in a new tab)
- github.com/mafintosh/tar-fs/commit/a1dd7e7c7f4b4a8bd2ab60f513baca573b44e2ed (opens in a new tab)
- arxiv.org/abs/2506.04962 (opens in a new tab)
- arxiv.org/pdf/2506.04962 (opens in a new tab)
- github.com/mafintosh/tar-fs (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/06/msg00012.html (opens in a new tab)
- seal.security/blog/a-link-to-the-past-uncovering-a-new-vulnerability-in-tar-fs (opens in a new tab)