Temporal Server compiles a Worker Controller Instance module, go.temporal.io/auto-scaled-workers, into its Worker
Affects auto-scaled-workersSource GCVE Database
Not known to be exploited · CVSS 8.7 High.
Data as of 3 Nov 2026, 01:29 UTC
Thin evidence
One scorer or none| CNA (Temporal) | CVSS 4.0 | 8.7 |
|---|
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Gogo.temporal.io/auto-scaled-workerspkg:golang/go.temporal.io/auto-scaled-workersOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Temporal Server to version 1.31.3 or later, or 1.32.0 or later, where the compute provider allowlist denies the k8s provider by default. Alternatively, explicitly configure the dynamic setting workercontroller.compute_providers.enabled to exclude the k8s provider. Deployments on 1.31.0 through 1.31.2 should set this allowlist to deny k8s or upgrade. Verify that authorization is properly configured and that the ValidateWorkerDeploymentVersionComputeConfig operation is not accessible to users without namespace write permissions. The 1.30 release line is not affected and does not require changes. No other immediate actions are required if these conditions are met.
Description
Temporal Server versions 1.31.0 through 1.31.2 include a Worker Controller Instance module with a Kubernetes compute provider (k8s) that uses client configuration from the caller's request. This allows an authenticated user with only read access in a namespace to execute arbitrary commands on the Worker Service host, potentially impacting the entire Kubernetes cluster. The vulnerability arises because the default configuration in these versions permits the k8s provider without restriction. Later versions (1.31.3 and above) deny this by default unless explicitly enabled. The 1.30 release line is unaffected as it lacks this module.
References
- nvd.nist.gov/vuln/detail/CVE-2026-120091 (opens in a new tab)
- github.com/temporalio/temporal-auto-scaled-workers/pull/165 (opens in a new tab)
- github.com/temporalio/temporal/pull/12843 (opens in a new tab)
- github.com/temporalio/temporal/releases/tag/v1.31.5 (opens in a new tab)
- github.com/temporalio/temporal/releases/tag/v1.32.2 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-89139 (opens in a new tab)