Skip to main content
CVE-2026-122006VulnerabilityPublished

The activestorage gem before 8.1.4.1 for Ruby on Rails, when ImageMagick attachment processing occurs, can allow

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-122006· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 8.1.4.1 or 8.0.5.2 as a priority.

Data as of 4 Nov 2026, 16:33 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.19.8
Patch
Available – fixed in 8.1.4.1, 8.0.5.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Active Storage to 8.1.4.1 or 8.0.5.2.

Affected software

ProductAffectedFixed in
rubyonrailsActive StorageAffected
  • >=8.1 <8.1.4.1
Fixed in
  • 8.1.4.1
rubyonrailsActive StorageAffected
  • <8.0.5.2
Fixed in
  • 8.0.5.2
RubyGemsActive Storagepkg:gem/Active StorageOther threatsAffected
  • <8.0.5.2
  • >=8.1 <8.1.4.1
Fixed in
  • 8.0.5.2
  • 8.1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in activestorage gem version 8.1.4.1 and later. Users should upgrade to version 8.1.4.1 or above to remediate this vulnerability. Until patched, applying an appropriate ImageMagick security policy to block unintended functionality during attachment processing is recommended if upgrading is not immediately possible.

Description

A critical vulnerability exists in the activestorage gem for Ruby on Rails versions before 8.1.4.1. When processing attachments using ImageMagick, the lack of an ImageMagick security policy allows the ImageMagick analyzer to perform unintended server read and write operations, potentially exposing sensitive data such as secret_key_base.

References

Community reviews

Loading reviews…