Skip to main content
VulnerabilityPublished

CVE-2025-5769: The authentication endpoint does not properly encode user-supplied input before rendering it within

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-5769· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.5.0.11 when convenient.

Data as of 3 Nov 2026, 10:44 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (WSO2)CVSS 3.16.1
Patch
Available – fixed in 4.5.0.11, 4.5.0.10, 4.4.0.26 +11
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 API Control PlaneAffected
  • >=4.5.0 <4.5.0.11
Fixed in
  • 4.5.0.11
WSO2WSO2 API ManagerAffected
  • >=4.5.0 <4.5.0.10
Fixed in
  • 4.5.0.10
WSO2WSO2 API ManagerAffected
  • >=4.4.0 <4.4.0.26
Fixed in
  • 4.4.0.26
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.63
Fixed in
  • 4.3.0.63
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.150
Fixed in
  • 4.2.0.150
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.212
Fixed in
  • 4.1.0.212

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the vulnerability involves improper output encoding, remediation requires implementing proper encoding of user-supplied input before rendering it in the web page to prevent script injection. If you cannot patch yet, users should be cautious with links to the authentication endpoint and avoid interacting with suspicious content.

Description

CVE-2025-5769 is a cross-site scripting (XSS) vulnerability in an authentication endpoint where user input is not properly encoded before being rendered on the web page. This flaw allows attackers to inject malicious JavaScript that executes in the victim's browser, potentially redirecting users, altering page content, or stealing information. The vulnerability does not allow session hijacking due to the use of the httpOnly flag on session cookies.

References

Community reviews

Loading reviews…