Skip to main content
CVE-2026-114422VulnerabilityPublished

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored

Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-114422· High

Not known to be exploited : upgrade to 4.2.3 soon.

Data as of 30 Oct 2026, 07:02 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 4.2.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Enable Media Replace (WordPress plugin) to 4.2.3.

Affected software

ProductAffectedFixed in
Enable Media ReplaceAffected
  • >=4.1.4 <4.2.3
Fixed in
  • 4.2.3

AI-suggested

Upgrade the Enable Media Replace plugin to version 4.2.3 or later where this vulnerability is fixed. Since this is a regression issue, ensure that the plugin version is not between 4.1.4 and 4.2.2 inclusive. No other mitigation steps are indicated in the provided data.

Description

The Enable Media Replace WordPress plugin versions before 4.2.3 contain a vulnerability where deserialization of stored metadata does not restrict allowed classes. This flaw allows unauthenticated attackers to inject PHP objects that are instantiated during media replacement by users with upload access, leading to PHP Object Injection and local file inclusion. The vulnerability can escalate to remote code execution if an attacker-controlled PHP or HTML file exists on the server. This issue is a regression of CVE-2023-4643, which was fixed in version 4.1.3 but reintroduced in 4.1.4.

References

Community reviews

Loading reviews…