The Essential Addons for Elementor WordPress plugin before 6.8.8 does not correctly restrict who may set the role
Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited : upgrade to 6.8.8 soon.
Data as of 31 Oct 2026, 07:08 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 6.8.8
Exploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Essential Addons for Elementor (WordPress plugin) to 6.8.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Essential Addons for Elementor | Affected
| Fixed in
|
AI-suggested
Upgrade the Essential Addons for Elementor WordPress plugin to version 6.8.8 or later, where the role assignment restriction is properly enforced. Versions 6.6.0 through 6.8.7 remain vulnerable despite the partial fix, so updating beyond 6.8.7 is necessary to fully remediate this issue.
Description
The Essential Addons for Elementor WordPress plugin versions before 6.8.8 improperly restrict which users can assign roles to accounts created via its registration form. Authenticated users with Author-level access or higher can escalate the roles of newly registered accounts, including those created by unauthenticated visitors, to higher privileges such as Editor. This issue is a partial regression of CVE-2026-5193, as the role-validation controls introduced in version 6.6.0 can be bypassed by lower-privileged users, leaving versions 6.6.0 through 6.8.7 vulnerable.