Skip to main content
CVE-2026-91049VulnerabilityPublished

The EWWW Image Optimizer WordPress plugin before 8.9.1 does not properly sanitize and restrict a value in post content

Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-91049· High

Not known to be exploited : upgrade to 8.9.1 soon.

Data as of 5 Nov 2026, 07:15 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 8.9.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade EWWW Image Optimizer (WordPress plugin) to 8.9.1.

Affected software

ProductAffectedFixed in
EWWW Image OptimizerAffected
  • >=8.7.4 <8.9.1
Fixed in
  • 8.9.1

AI-suggested

Upgrade the EWWW Image Optimizer WordPress plugin to version 8.9.1 or later, where the vulnerability is fixed. Versions 8.7.4 through 8.9.0 remain vulnerable due to bypassable origin and path restrictions. No other mitigation is indicated by the vendor advisory.

Description

The EWWW Image Optimizer WordPress plugin versions before 8.9.1 contain a vulnerability that allows authenticated users with author-level access or higher to inject arbitrary web scripts via post content. This occurs because the plugin does not properly sanitize and restrict certain values before dynamically loading and executing scripts on the page. The issue is a partial regression of CVE-2026-15446, as the origin and path restrictions introduced in versions 8.7.4 through 8.9.0 can be bypassed, leaving these versions vulnerable.

References

Community reviews

Loading reviews…