Skip to main content
CVE-2026-114427VulnerabilityPublished

The GutenKit WordPress plugin before 2.5.5 does not properly sanitize custom CSS saved against a post before printing

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-114427· High

Not known to be exploited : upgrade to 2.5.5 soon.

Data as of 6 Nov 2026, 07:21 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.5.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade GutenKit (WordPress plugin) to 2.5.5.

Affected software

ProductAffectedFixed in
GutenKitAffected
  • >=2.5.0 <2.5.5
Fixed in
  • 2.5.5

AI-suggested

Upgrade the GutenKit WordPress plugin to version 2.5.5 or later, where proper sanitization of custom CSS is implemented. Additionally, ensure WordPress is updated to version 7.0 or later to avoid related compatibility issues. No other mitigation is indicated.

Description

The GutenKit WordPress plugin versions before 2.5.5 improperly sanitize custom CSS saved against posts, allowing users with Author role and above to inject JavaScript that executes in visitors' browsers. This vulnerability affects sites running WordPress versions below 7.0.

References

Community reviews

Loading reviews…