The MC4WP: Mailchimp for WordPress WordPress plugin before 4.15.0 does not prevent request-derived values in its
Source GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 4.15.0 when convenient.
Data as of 6 Nov 2026, 10:47 UTC
Thin evidence
One scorer or none| CNA (WPScan) | CVSS 3.1 | 4.8 |
|---|
- Patch
- Available – fixed in 4.15.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade MC4WP: Mailchimp for WordPress to 4.15.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MC4WP: Mailchimp for WordPress | Affected
| Fixed in
|
AI-suggested
Upgrade the MC4WP: Mailchimp for WordPress plugin to version 4.15.0 or later, where this issue is fixed. Until then, avoid adding request-derived tags to form content and embedding forms using the block method.
Description
The MC4WP: Mailchimp for WordPress plugin versions before 4.15.0 have a vulnerability where request-derived values in dynamic content tags are processed as shortcodes when a form is embedded using its block. This allows unauthenticated visitors to execute arbitrary registered shortcodes with attacker-chosen attributes, but only if the site owner has added a request-derived tag to the form content and uses the block embedding method instead of the classic shortcode.