The PDF Invoices & Packing Slips for WooCommerce WordPress plugin from 5.16.2 before 5.16.5 does not properly escape
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 5.16.5 soon.
Data as of 31 Oct 2026, 01:38 UTC
Thin evidence
One scorer or none| CNA (WPScan) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 5.16.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade PDF Invoices & Packing Slips for WooCommerce (WordPress plugin) to 5.16.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PDF Invoices & Packing Slips for WooCommerce | Affected
| Fixed in
|
AI-suggested
A fix is available in version 5.16.5 of the plugin. Users should upgrade to version 5.16.5 or later to remediate this vulnerability. No other mitigation steps are indicated.
Description
A stored cross-site scripting (XSS) vulnerability exists in the PDF Invoices & Packing Slips for WooCommerce WordPress plugin versions from 5.16.2 up to but not including 5.16.5. The plugin does not properly escape certain customer-supplied order fields, such as billing and shipping addresses and customer order notes, in generated invoice and packing-slip documents. This allows unauthenticated users placing guest orders to inject malicious scripts that execute when a shop administrator views these documents.