The Webheadcoder Multi-Step Forms for Contact Form 7 plugin for WordPress is vulnerable to Reflected Cross-Site
Source GCVE Database
Not known to be exploited · CVSS 6.1 Medium.
Data as of 28 Oct 2026, 10:14 UTC
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| webheadllcWebheadcoder Multi-Step Forms for Contact Form 7 | Affected
| Fixed in– |
AI-suggested
Users should upgrade beyond version 4.7 if a fixed version becomes available. Until then, avoid using multistep forms with this plugin or apply custom input sanitization and output escaping as a temporary mitigation. Monitor vendor advisories for updates.
Description
The Webheadcoder Multi-Step Forms for Contact Form 7 WordPress plugin is vulnerable to reflected cross-site scripting (XSS) via the 'l10n_print_after' parameter in all versions up to and including 4.7. This vulnerability arises from insufficient input sanitization and output escaping, allowing unauthenticated attackers to inject arbitrary scripts. Exploitation requires the targeted site to have at least one Contact Form 7 form configured with a [multistep] form-tag, as version 4.7 introduced canonicalization that blocks the attack on non-multistep forms.
References
- nvd.nist.gov/vuln/detail/CVE-2026-92098 (opens in a new tab)
- github.com/coreyt808/webheadcoder-multi-step-forms-for-contact-form-7/commit/16f71561797b71548021dc9c4e30b0456e718cd3 (opens in a new tab)
- plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7.1/cf7msm.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/contact-form-7-multi-step-module/tags/4.7/cf7msm.php (opens in a new tab)
- wordfence.com/threat-intel/vulnerabilities/id/6fa810af-e620-49e5-9be0-f9fc4d09ed6d?source=cve (opens in a new tab)