Skip to main content
VulnerabilityPublished

CVE-2025-11983: The WP Discourse plugin for WordPress is vulnerable to Information Exposure in all versions up to

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-11983· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium · fixed in 2.6.0 : update affected systems when convenient.

Data as of 29 Oct 2026, 23:38 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.6.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

Users should restrict author-level access to trusted users and monitor for suspicious activity involving Discourse API credentials. Review and sanitize the discourse_permalink custom field inputs to prevent sending credentials to untrusted hosts.

Description

The WP Discourse plugin for WordPress versions up to and including 2.5.9 has an information exposure vulnerability. The plugin sends Discourse API credentials unconditionally to any host specified in a post's discourse_permalink custom field during comment synchronization. This allows authenticated users with author-level access or higher to exfiltrate sensitive API credentials to attacker-controlled servers and potentially query internal services.

References

Community reviews

Loading reviews…