Skip to main content
VulnerabilityPublished

CVE-2026-16620: The WPC Name Your Price for WooCommerce WordPress plugin before 2.2.5 does not enforce its server-side price allowlist for products configured in

Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-16620· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2.2.5 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by WPScan

    , 15 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 21 hours after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade WPC Name Your Price for WooCommerce (WordPress plugin) to 2.2.5.

Affected software

ProductAffectedFixed in
WPC Name Your Price for WooCommerceAffected
  • <2.2.5
Fixed in
  • 2.2.5

Description

The WPC Name Your Price for WooCommerce WordPress plugin versions before 2.2.5 contain a vulnerability where the server-side price allowlist is not enforced for products configured in "Select" price mode. This allows unauthenticated visitors to add products to the cart at arbitrary prices below the allowed values and place orders at those underpriced amounts, potentially causing revenue loss. This issue is distinct from a previous vulnerability fixed in version 2.2.0 and remains unpatched through 2.2.4.

References

Community reviews

Loading reviews…