The WPC Name Your Price for WooCommerce WordPress plugin versions before 2.2.5 contain a vulnerability where the server-side price allowlist is not enforced for products configured in "Select" price mode. This allows unauthenticated visitors to add products to the cart at arbitrary prices below the allowed values and place orders at those underpriced amounts, potentially causing revenue loss. This issue is distinct from a previous vulnerability fixed in version 2.2.0 and remains unpatched through 2.2.4.