Skip to main content
VulnerabilityPublished

CVE-2026-118546: drupal/ai · This module enables you to use AI on the website

Affects drupal/aiSource GCVE Database

0

Not known to be exploited : upgrade to 1.5.2 or 1.4.11 when convenient.

Data as of 28 Oct 2026, 20:43 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 1.5.2, 1.4.11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/ai to 1.5.2 or 1.4.11.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/aiAffected
  • <1.4.11
  • >=1.5.0 <1.5.2
Fixed in
  • 1.4.11
  • 1.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official fixes by upgrading to Drupal AI module versions 1.4.11 or 1.5.2. Since a patch is available, remediation should be performed promptly to eliminate the vulnerability. No additional mitigations are specified.

Description

The Drupal AI module includes an AI Chatbot submodule that under certain configurations does not properly filter user input before rendering, leading to a potential cross-site scripting (XSS) vulnerability. Exploitation requires attacker access to administer blocks, limiting the attack surface. Fixed versions 1.4.11 and 1.5.2 address this issue.

References

Community reviews

Loading reviews…