Skip to main content
CVE-2025-46701VulnerabilityPublished Updated

Tomcat6: Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint

Affects tomcat6Source GCVE Database

0
Authoritative record:CVE-2025-46701· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 10.1.16-1ubuntu0.1~esm3 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
3.1% chance of exploitation in 30 days – higher than 87% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.1.16-1ubuntu0.1~esm3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu tomcat10 package to 10.1.16-1ubuntu0.1~esm3.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–
Ubuntu 25.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=questingOther threatsAffected
  • =11.0.6-1
Fixed in–
Ubuntu Pro 24.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <10.1.16-1ubuntu0.1~esm3
Fixed in
  • 10.1.16-1ubuntu0.1~esm3
Ubuntu Pro 22.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 9.0.43-3 – 9.0.58-1ubuntu0.2+esm4
14 affected builds
Fixed in–
Ubuntu Pro 20.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/focalOther threatsAffected
  • 9.0.24-1 – 9.0.31-1ubuntu0.9+esm3
15 affected builds
Fixed in–
Ubuntu Pro 18.04 LTStomcat8pkg:deb/ubuntu/tomcat8?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 8.5.21-1ubuntu1 – 8.5.39-1ubuntu1~18.04.3+esm6
16 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

References

Community reviews

Loading reviews…