Tomcat6: Missing Critical Step
Affects tomcat6Source GCVE Database
Not known to be exploited · CVSS 7.3 High · fixed in 11.0.5 : patch tomcat6 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 2.8% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
References
- ubuntu.com/security/CVE-2026-55957 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-55957 (opens in a new tab)
- github.com/apache/tomcat/commit/fd96ab415631eea44636c94f911dd38427070ef9 (opens in a new tab)
- github.com/apache/tomcat/commit/0cd21c0393b8811af22daddbba7b4e7328e2d79e (opens in a new tab)
- github.com/apache/tomcat/commit/c32bbd37ea9ee0aaab848af4ee1c9a76e84240ea (opens in a new tab)
- lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjh (opens in a new tab)
- openwall.com/lists/oss-security/2026/06/29/26 (opens in a new tab)