CVE-2025-55752: Tomcat8 · Relative Path Traversal vulnerability in Apache Tomcat
Affects tomcat8Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · 64% EPSS · CVSS 7.5 High · fixed in 11.0.11 : patch tomcat8 as a priority.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 64.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.0.11
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
References
- ubuntu.com/security/CVE-2025-55752 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-55752 (opens in a new tab)
- lists.apache.org/thread/n05kjcwyj1s45ovs8ll1qrrojhfb1tog (opens in a new tab)
- github.com/apache/tomcat/commit/fec06c610ed7466b401e29cc567a58aee5ed826a (opens in a new tab)
- github.com/apache/tomcat/commit/130d36d8492ef9e4eb22952c17c92423cb35fd06 (opens in a new tab)
- github.com/apache/tomcat/commit/b5042622b8b78340ae65403c55dcb9c7416924df (opens in a new tab)