CVE-2025-55752: Apache Tomcat · Relative Path Traversal
Affects Apache TomcatSource CVE Database V5
Not known to be exploited · 64% EPSS · CVSS 7.5 High · fixed in 11.0.11 : patch Apache Tomcat as a priority.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 64.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.0.11
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available. Users should upgrade Apache Tomcat to version 11.0.11 or later, 10.1.45 or later, or 9.0.109 or later to remediate this vulnerability. There is no indication that the vulnerability is mitigated by default configurations beyond this upgrade. Disabling PUT requests if not required may reduce risk but does not replace applying the official fix.
Description
Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
References
- lists.apache.org/thread/n05kjcwyj1s45ovs8ll1qrrojhfb1tog (opens in a new tab)
- openwall.com/lists/oss-security/2025/10/27/4 (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2025-55752-detect-apache-tomcat-vulnerability (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2025-55752-mitigate-apache-tomcat-vulnerability (opens in a new tab)
- cert-portal.siemens.com/productcert/html/ssa-032379.html (opens in a new tab)