Skip to main content
CVE-2025-66451VulnerabilityPublished

CVE-2025-66451: danny-avila LibreChat · Improper Input Validation

Affects danny-avila LibreChatSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.8.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade danny-avila/LibreChat to 0.8.1.

Affected software

ProductAffectedFixed in
GitHubdanny-avila/LibreChatpkg:github/danny-avila/LibreChatOther threatsAffected
  • <0.8.1
Fixed in
  • 0.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade LibreChat installations to version 0.8.1 or later, where the vulnerability is patched. If upgrading is not immediately feasible, implement strict input validation and sanitization on the server side for the PATCH /api/prompts/groups/:groupId endpoint to ensure only allowed fields are modified. Employ API gateway or web application firewall (WAF) rules to detect and block anomalous JSON payloads attempting to alter sensitive fields. Restrict access to the prompt group modification API to authenticated and authorized users only, even if the vulnerability does not require authentication, to reduce attack surface. Monitor logs for unusual PATCH requests or prompt modifications indicative of exploitation attempts. Conduct regular security audits and penetration testing focused on API endpoints handling user input. Educate developers and administrators about secure coding practices, emphasizing input validation and least privilege principles. Finally, maintain an incident response plan to quickly address any detected exploitation.

Description

LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.

References

Community reviews

Loading reviews…