CVE-2026-116577: Tornado · Quadratic CPU usage when parsing HTTP headers with line folding
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.6.4_3 when convenient.
Data as of 30 Oct 2026, 09:00 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.3 |
|---|
- Patch
- Available – fixed in 4.6.4_3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.6.4_3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Tornado version 4.6.4_3, which removes support for obsolete line folding and rejects header lines beginning with whitespace. Users should upgrade to this version to fully remediate the vulnerability. As a workaround, keeping max_header_size at the default value or lowering it can limit the impact but does not eliminate the vulnerability. Running Tornado behind a reverse proxy that rejects or normalizes obsolete line folding before forwarding requests can also mitigate the issue.
Description
Tornado HTTP servers have a vulnerability in their header parser that causes quadratic CPU usage when processing HTTP headers with obsolete line folding (line continuation). This can lead to significant event loop blocking and degraded service availability. The issue affects all Tornado HTTP servers before version 4.6.4_3. The vulnerability is fixed in Tornado 4.6.4_3 by removing support for obsolete line folding and rejecting header lines beginning with whitespace. The impact is limited to availability; confidentiality and integrity are not affected.
References
- github.com/tornadoweb/tornado/security/advisories/GHSA-pcg2-g6cj-q92c (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-116577 (opens in a new tab)
- github.com/tornadoweb/tornado/pull/3765 (opens in a new tab)
- github.com/tornadoweb/tornado/commit/1b7a1dc9f340f52de929852e8125aa12f25297c9 (opens in a new tab)
- github.com/tornadoweb/tornado (opens in a new tab)
- github.com/tornadoweb/tornado/releases/tag/v6.6.0 (opens in a new tab)