Skip to main content
CVE-2026-121966VulnerabilityPublished

Traefik 2.x before 2.11.60 and 3.x before 3.7.16 sends ForwardAuth subrequests (and, in 3.7, Ingress NGINX auth-url

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121966· High 7.0

Not known to be exploited · CVSS 7.0 High : upgrade to 2.11.60 soon.

Data as of 4 Nov 2026, 19:45 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.0
CNA (VulnCheck)CVSS 3.18.7
Patch
Available – fixed in 2.11.60, 3.7.16
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade traefik to 2.11.60; traefik to 3.7.16; traefik to 3.7.16 or 2.11.60.

Affected software

ProductAffectedFixed in
traefiktraefikAffected
  • <2.11.60
Fixed in
  • 2.11.60
traefiktraefikAffected
  • >=3.0.0 <3.7.16
Fixed in
  • 3.7.16
Gotraefikpkg:golang/traefikOther threatsAffected
  • <2.11.60
  • >=3.0.0 <3.7.16
Fixed in
  • 2.11.60
  • 3.7.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Traefik versions 2.11.60 and later for the 2.x branch, and 3.7.16 and later for the 3.x branch. Users should upgrade to these versions to remediate the vulnerability. No other mitigation steps are indicated.

Description

Traefik versions 2.x before 2.11.60 and 3.x before 3.7.16 have a vulnerability where ForwardAuth subrequests and Ingress NGINX auth-url requests are sent through a shared auth-server connection pool. This can expose connection-bound NTLM or Negotiate authentication tokens. An unauthenticated attacker can reuse another user's authenticated connection and impersonate that user to access backend services.

References

Community reviews

Loading reviews…