Skip to main content
CVE-2025-52520VulnerabilityPublished Updated

Tomcat6: For some unlikely configurations of multipart upload, an Integer Overflow vulnerability in Apache Tomcat

Affects tomcat6Source GCVE Database

0
Authoritative record:CVE-2025-52520· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 11.0.9 : patch tomcat6 soon.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.1% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threatsAffected
  • 10.1.40-1ubuntu1 – 10.1.57~us1-0ubuntu1
7 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–
Ubuntu 25.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=questingOther threatsAffected
  • 10.1.35-1 – 10.1.40-1ubuntu1.25.10.1
4 affected builds
Fixed in–
Ubuntu 25.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=questingOther threatsAffected
  • =11.0.6-1
Fixed in–
Ubuntu 24.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=nobleOther threatsAffected
  • 10.1.10-1 – 10.1.55-1ubuntu2~24.04.1
9 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

For some unlikely configurations of multipart upload, an Integer Overflow vulnerability in Apache Tomcat could lead to a DoS via bypassing of size limits. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.

References

Community reviews

Loading reviews…