U-Boot before 2026.07-rc2 contains a buffer overflow vulnerability in nfs_readlink_reply() (net/nfs-common.c) when
Affects u-bootSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical · fixed in 2026.07 : patch u-boot as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.07
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10u-bootpkg:deb/ubuntu/u-boot?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSu-bootpkg:deb/ubuntu/u-boot?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10u-bootpkg:deb/ubuntu/u-boot?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSu-bootpkg:deb/ubuntu/u-boot?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSu-boot-nezhapkg:deb/ubuntu/u-boot-nezha?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSu-bootpkg:deb/ubuntu/u-boot?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in U-Boot version 2026.07-rc2 and later. Users should upgrade to version 2026.07-rc2 or newer to remediate this vulnerability. No vendor advisory was provided in the input, so check the official U-Boot or distribution vendor advisories for patch availability and deployment instructions.
Description
U-Boot versions before 2026.07-rc2 contain a buffer overflow vulnerability in the nfs_readlink_reply() function when CONFIG_CMD_NFS is enabled. This vulnerability allows a malicious or compromised NFS server to overflow a 2048-byte buffer by sending multiple relative symlink targets without proper length validation. Exploitation can corrupt adjacent memory variables, potentially allowing control over the NFS client state machine.