Skip to main content
VulnerabilityPublished Updated

CVE-2026-43514: Tomcat6 · Observable Timing Discrepancy vulnerability when comparing AJP secret in Apache Tomcat

Affects tomcat6Source GCVE Database

0
Compare
Authoritative record:CVE-2026-43514· Low 3.7

Not known to be exploited · CVSS 3.7 Low · fixed in 11.0.22 : update tomcat6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.22
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threatsAffected
  • 10.1.40-1ubuntu1 – 10.1.57~us1-0ubuntu1
7 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threatsAffected
  • 9.0.95-1ubuntu1 – 9.0.118-1~26.04.1
5 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–
Ubuntu 25.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=questingOther threatsAffected
  • 10.1.35-1 – 10.1.40-1ubuntu1.25.10.1
4 affected builds
Fixed in–
Ubuntu 25.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=questingOther threatsAffected
  • =11.0.6-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade Apache Tomcat to versions 11.0.22, 10.1.55, or 9.0.118 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

An observable timing discrepancy vulnerability exists in Apache Tomcat when comparing the AJP secret. This vulnerability affects multiple versions across several major Tomcat branches. The issue is addressed in Apache Tomcat versions 11.0.22, 10.1.55, and 9.0.118. Users are advised to upgrade to these fixed versions to remediate the vulnerability. The CVSS score is 3.7, indicating a medium severity level.

References

Community reviews

Loading reviews…