Skip to main content
VulnerabilityPublished Updated

CVE-2026-66299: Tomcat6 · Uncontrolled Resource Consumption vulnerability in Apache Tomcat's WebSocket chat example

Affects tomcat6Source GCVE Database

0
Authoritative record:CVE-2026-66299· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 11.0.25 : patch tomcat6 soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.25, 10.1.58, 9.0.121
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade tomcat to 11.0.25, 10.1.58 or 9.0.121.

Affected software

ProductAffectedFixed in
Bitnamitomcatpkg:bitnami/tomcatOther threatsAffected
  • <9.0.121
  • >=10.1.24 <10.1.58
  • >=11.0.0 <11.0.25
Fixed in
  • 9.0.121
  • 10.1.58
  • 11.0.25
Ubuntu Pro 14.04 LTStomcat6pkg:deb/ubuntu/tomcat6?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 6.0.37-1 – 6.0.39-1ubuntu0.1+esm3
6 affected builds
Fixed in–
Ubuntu Pro 14.04 LTStomcat7pkg:deb/ubuntu/tomcat7?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 7.0.42-1 – 7.0.52-1ubuntu0.16+esm2
18 affected builds
Fixed in–
Ubuntu Pro 16.04 LTStomcat8pkg:deb/ubuntu/tomcat8?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 8.0.26-1 – 8.0.32-1ubuntu1.13+esm2
19 affected builds
Fixed in–
Ubuntu Pro 16.04 LTStomcat7pkg:deb/ubuntu/tomcat7?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • 7.0.64-1 – 7.0.68-1ubuntu0.4+esm4
9 affected builds
Fixed in–
Ubuntu Pro 18.04 LTStomcat8pkg:deb/ubuntu/tomcat8?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 8.5.21-1ubuntu1 – 8.5.39-1ubuntu1~18.04.3+esm6
16 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users are recommended to remove the examples web application to mitigate the vulnerability. Alternatively, upgrading to Apache Tomcat versions 11.0.25, 10.1.58, or 9.0.121 (when released) will fix the issue. No other mitigation is indicated by the vendor advisory.

Description

Uncontrolled Resource Consumption vulnerability in Apache Tomcat's WebSocket chat example. This issue affects Apache Tomcat: from 11.0.0 through 11.0.24, from 10.1.24 through 10.1.57, from 9.0.89 through 9.0.120. Users who have followed the security guidance to remove the examples web application are not affected by this issue. Users are recommended to remove the examples web application or to upgrade to version 11.0.25, 10.1.58 or 9.0.121 (when released), which fix the issue.

References

Community reviews

Loading reviews…