CVE-2026-44681: Python authlib · Prior to 1.6.12 and 1.7.1, an unauthenticated open redirect in Authlib's OpenIDImplicitGrant and OpenIDHybridGrant authorization endpoint lets a
Affects python-authlibSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium · fixed in 2.14.0_4 : update python-authlib when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.0_4, 1.41.0_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcpm to 2.14.0_4; kimi-cli to 1.41.0_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 22.04 LTSpython-authlibpkg:deb/ubuntu/python-authlib?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSpython-authlibpkg:deb/ubuntu/python-authlib?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu 25.10python-authlibpkg:deb/ubuntu/python-authlib?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSpython-authlibpkg:deb/ubuntu/python-authlib?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Homebrewmcpmpkg:brew/mcpmOther threats | Affected
| Fixed in
|
Homebrewkimi-clipkg:brew/kimi-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Authlib versions 1.6.12 and 1.7.1 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No additional mitigation is required if the software is updated accordingly.
Description
Authlib versions prior to 1.6.12 and 1.7.1 contain an unauthenticated open redirect vulnerability in the OpenIDImplicitGrant and OpenIDHybridGrant authorization endpoints. This flaw is triggered by omitting the 'openid' scope in authorization requests, causing the server to redirect to an attacker-chosen URL without validating the redirect URI. The vulnerability affects servers supporting OpenID Connect Implicit or Hybrid flows and can be exploited without authentication or valid client IDs. While it does not directly leak tokens or authorization codes, it enables phishing attacks by leveraging the trusted authorization server's domain in the browser's URL bar. A fix is available for this vulnerability.
References
- ubuntu.com/security/CVE-2026-44681 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-44681 (opens in a new tab)
- github.com/authlib/authlib/security/advisories/GHSA-r95x-qfjj-fjj2 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44681 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.6.12 (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.7.1 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/authlib/PYSEC-2026-188.yaml (opens in a new tab)