Skip to main content
VulnerabilityPublished Updated

CVE-2026-47329: Linux hwe edge · Ubuntu Linux 6.8, 6.17 and 7.0 contain SAUCE patches which fail to validate invalid

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-47329· Low 3.3

Not known to be exploited · CVSS 3.3 Low · fixed in 6.8.0-1057.60~22.04.1 : update Linux kernel when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
3.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.09% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1057.60~22.04.1, 6.8.0-1059.65~22.04.1, 6.8.0-1058.65~22.04.1 +53
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-22.22
Fixed in
  • 7.0.0-22.22
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.6
Fixed in
  • 7.0.0-1006.6
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.6
Fixed in
  • 7.0.0-1006.6
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1005.5
Fixed in
  • 7.0.0-1005.5
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available from Ubuntu. Users should apply the security updates provided in Ubuntu Security Notices USN-8370-1 and USN-8371-1, which include fixes for CVE-2026-47329 among other kernel vulnerabilities. After updating the kernel packages, a system reboot is required to activate the fixes. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigation actions are required beyond applying the official updates.

Description

Ubuntu Linux kernels 6.8, 6.17, and 7.0 include patches (SAUCE patches) that fail to properly validate the size of the name field in AppArmor notification responses. This vulnerability (CVE-2026-47329) can be triggered by an unprivileged local user and may allow crafted AppArmor responses to be processed improperly. The issue is part of a set of multiple AppArmor-related flaws affecting these kernel versions. The CVSS score is low (3.3) indicating limited impact. A patch is available from Ubuntu and users are advised to update and reboot to apply fixes.

References

Community reviews

Loading reviews…