Skip to main content
CVE-2026-47333VulnerabilityPublished Updated

Linux hwe edge: Ubuntu Linux 6.8, 6.17 and 7.0 contain AppArmor SAUCE patches which can potentially incorrectly

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-47333· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-1057.60~22.04.1 : patch Linux kernel soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1057.60~22.04.1, 6.8.0-1059.65~22.04.1, 6.8.0-1058.65~22.04.1 +53
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-22.22
Fixed in
  • 7.0.0-22.22
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.6
Fixed in
  • 7.0.0-1006.6
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.6
Fixed in
  • 7.0.0-1006.6
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1005.5
Fixed in
  • 7.0.0-1005.5
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available from Ubuntu to address this vulnerability. Users should update their systems to the fixed kernel package versions as listed in the Ubuntu security notices USN-8370-1 and USN-8371-1 and reboot the system to apply the changes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. No additional mitigation actions are specified by the vendor.

Description

Ubuntu Linux kernels 6.8, 6.17, and 7.0 contain AppArmor patches that incorrectly compute the size of an internal buffer, resulting in a heap out-of-bounds read during notification handling. This vulnerability can be triggered by an unprivileged local user and may lead to kernel memory corruption and potentially influence AppArmor policy processing. The issue is tracked as CVE-2026-47333 and has a high severity with a CVSS score of 7.8. Multiple affected versions are identified, and a patch is available from Ubuntu.

References

Community reviews

Loading reviews…