Skip to main content
VulnerabilityPublished Updated

CVE-2026-50229: Tomcat6 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability

Affects tomcat6Source GCVE Database

0
Compare
Authoritative record:CVE-2026-50229· Medium 6.1

Exposed hosts seen by OffSeq Mirage · public detection template (Nuclei) · CVSS 6.1 Medium · fixed in 8.0.32-1ubuntu1.13+esm2 : update tomcat6 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.0% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.32-1ubuntu1.13+esm2, 8.5.39-1ubuntu1~18.04.3+esm6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: evidence found.

    3 exposed hosts found; no attack traffic recorded

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu tomcat8 to 8.0.32-1ubuntu1.13+esm2 (package) or 8.5.39-1ubuntu1~18.04.3+esm6 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threatsAffected
  • 10.1.40-1ubuntu1 – 10.1.57~us1-0ubuntu1
7 affected builds
Fixed in–
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threatsAffected
  • 11.0.18-1 – 11.0.24-1ubuntu1
5 affected builds
Fixed in–
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threatsAffected
  • =9.0.115-1
  • =9.0.115-1ubuntu1
  • =9.0.118-1
Fixed in–
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threatsAffected
  • 9.0.95-1ubuntu1 – 9.0.118-1~26.04.1
5 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade affected Apache Tomcat installations to versions 11.0.23, 10.1.56, or 9.0.119 or later. Ubuntu users should apply the security updates provided in the Ubuntu Security Notice USN-8551-1, which includes patched packages for supported Ubuntu releases. Standard system updates will apply the necessary fixes. No additional action is required beyond applying these updates.

Description

A cross-site scripting (XSS) vulnerability exists in the number guess example application of Apache Tomcat. This vulnerability is due to improper neutralization of script-related HTML tags, allowing an attacker to inject malicious scripts. The issue affects multiple versions of Apache Tomcat, including versions from 7.0.0 through 7.0.109, 8.5.0 through 8.5.100, 9.0.0.M1 through 9.0.118, 10.1.0-M1 through 10.1.55, and 11.0.0-M1 through 11.0.22. Fixed versions have been released, and users are advised to upgrade to 11.0.23, 10.1.56, or 9.0.119 or later to remediate the issue. The vulnerability has a CVSS score of 6.1 (medium severity).

References

Community reviews

Loading reviews…