Skip to main content
VulnerabilityPublished Updated

CVE-2026-52747: modsecurity · Prior to 3.0.16, the multipart/form-data request body parser in libmodsecurity silently removes embedded line breaks from non-file form-field values

Affects modsecuritySource GCVE Database

0
Compare
Authoritative record:CVE-2026-52747· High 8.6

Not known to be exploited · CVSS 8.6 High · fixed in 3.0.16 : patch modsecurity soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10modsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=stonkingOther threatsAffected
  • =3.0.14-1build2
  • =3.0.15-1
  • =3.0.16-1
Fixed in–
Ubuntu 26.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=resoluteOther threatsAffected
  • =3.0.14-1build1
  • =3.0.14-1build2
Fixed in–
Ubuntu 24.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=nobleOther threatsAffected
  • 3.0.10-1 – 3.0.12-1.1build2
5 affected builds
Fixed in–
Ubuntu 22.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=jammyOther threatsAffected
  • =3.0.4-2
  • =3.0.6-1
Fixed in–
Ubuntu 20.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=focalOther threatsAffected
  • =3.0.3-1
  • =3.0.4-1
  • =3.0.4-1build1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ModSecurity to version 3.0.16 or later, where this issue is fixed. No other mitigations are indicated by the vendor advisory.

Description

ModSecurity versions prior to 3.0.16 have a vulnerability in the multipart/form-data request body parser that causes embedded line breaks in non-file form-field values to be silently removed. This behavior causes a mismatch between ModSecurity and backend applications, potentially allowing payloads relying on line breaks to bypass security rules inspecting ARGS or ARGS_POST. The issue is fixed in version 3.0.16.

References

Community reviews

Loading reviews…