Skip to main content
VulnerabilityPublished Updated

CVE-2026-52761: Modsecurity · From 3.0.0 through 3.0.15, the t:utf8toUnicode transformation in src/actions/transformations/utf8_to_unicode.cc produces wrong output on i386

Affects modsecuritySource GCVE Database

0
Compare
Authoritative record:CVE-2026-52761· Medium 5.8

Not known to be exploited · CVSS 5.8 Medium · fixed in 3.0.16 : update modsecurity when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10modsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=stonkingOther threatsAffected
  • =3.0.14-1build2
  • =3.0.15-1
  • =3.0.16-1
Fixed in–
Ubuntu 26.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=resoluteOther threatsAffected
  • =3.0.14-1build1
  • =3.0.14-1build2
Fixed in–
Ubuntu 24.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=nobleOther threatsAffected
  • 3.0.10-1 – 3.0.12-1.1build2
5 affected builds
Fixed in–
Ubuntu 22.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=jammyOther threatsAffected
  • =3.0.4-2
  • =3.0.6-1
Fixed in–
Ubuntu 20.04 LTSmodsecuritypkg:deb/ubuntu/modsecurity?arch=source&distro=focalOther threatsAffected
  • =3.0.3-1
  • =3.0.4-1
  • =3.0.4-1build1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ModSecurity to version 3.0.16 or later, where this vulnerability is fixed. No other mitigation is indicated.

Description

ModSecurity versions 3.0.0 through 3.0.15 contain a vulnerability in the t:utf8toUnicode transformation on i386 architectures. The issue is caused by incorrect use of snprintf with sizeof on a char pointer instead of the unicode buffer length, leading to wrong output. This flaw allows rules that use this transformation to be bypassed on affected systems. The vulnerability is fixed in version 3.0.16.

References

Community reviews

Loading reviews…