CVE-2026-54423: In OpenStack Ironic before 37.0.1, an Ironic user with the ability to deploy nodes using the IPMI management interface can maliciously use the
Affects ironicSource GCVE Database
Not known to be exploited · CVSS 8.2 High · fixed in 37.0.1 : patch ironic soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 37.0.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10ironicpkg:deb/ubuntu/ironic?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSironicpkg:deb/ubuntu/ironic?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10ironicpkg:deb/ubuntu/ironic?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSironicpkg:deb/ubuntu/ironic?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSironicpkg:deb/ubuntu/ironic?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSironicpkg:deb/ubuntu/ironic?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in OpenStack Ironic version 37.0.1 and later. Users should upgrade to version 37.0.1 or newer to remediate this vulnerability. Since this is not a cloud service, manual patching is required. No vendor advisory content contradicts this recommendation.
Description
OpenStack Ironic versions before 37.0.1 contain a vulnerability that allows an Ironic user with deployment permissions on IPMI-managed nodes to issue arbitrary IPMI commands via the send_raw step, bypassing access controls. This can lead to unauthorized command execution on managed nodes. The vulnerability affects multiple Ubuntu package versions of Ironic. No known exploits have been reported in the wild. The CVSS score is 8.2, indicating a high severity impact on availability and integrity with limited confidentiality impact.