CVE-2026-57213: Rabbitmq server · RabbitMQ is a messaging and streaming broker
Affects rabbitmq-serverSource GCVE Database
Not known to be exploited · CVSS 5.7 Medium · fixed in 3.13.14 : update rabbitmq-server when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.13.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server@3.8.3-0ubuntu0.3?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been fixed in RabbitMQ server versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5. Users should upgrade to these or later versions to remediate the issue. No additional mitigation is indicated by the vendor advisory.
Description
A cross-site scripting (XSS) vulnerability exists in the rabbitmq_federation_management plugin of RabbitMQ server versions prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5. This vulnerability allows a user with permission to configure federation upstreams or policies to inject JavaScript code that executes in the browsers of users viewing the Federation Status page. The issue has been fixed in the specified versions.
References
- ubuntu.com/security/CVE-2026-57213 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-57213 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/33dedfe4fd53ff009cc67ab36358d0624c6b2e53 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/c2d0d69edf01efbd6e87dfb250c373a32da957f8 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15708 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15711 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.5 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-qxrp-7cmp-p77h (opens in a new tab)