CVE-2026-57215: Rabbitmq server · RabbitMQ is a messaging and streaming broker
Affects rabbitmq-serverSource GCVE Database
Not known to be exploited · CVSS 7.0 High · fixed in 3.13.15 : patch rabbitmq-server soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.13.15
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server@3.8.3-0ubuntu0.3?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in RabbitMQ versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6 and later. Users should upgrade to these or newer versions to remediate the vulnerability.
Description
RabbitMQ versions prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6 contain a vulnerability involving missing deletion checks for volatile direct-reply-to queues. This allows foreign bindings to amq.rabbitmq.reply-to destinations, resulting in persistent route entries after unbind operations. The issue is fixed in the specified later versions.
References
- ubuntu.com/security/CVE-2026-57215 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-57215 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/9055500d10ca7629dd2b051c6dc7a4b0bb8f6734 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/c84f3c880e0f22b49c01237cf8f86e176eeadc72 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15935 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/15938 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-5cq3-v9jx-p3x3 (opens in a new tab)