CVE-2026-57219: Rabbitmq server · RabbitMQ is a messaging and streaming broker
Affects rabbitmq-serverSource GCVE Database
Not known to be exploited · public detection template (Nuclei) · CVSS 8.7 High · fixed in 3.13.15 : patch rabbitmq-server soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 2.8% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.13.15
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: evidence found.
nuclei template: RabbitMQ Management - OAuth 2 Client Secret Disclosure
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server@3.8.3-0ubuntu0.3?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSrabbitmq-serverpkg:deb/ubuntu/rabbitmq-server?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade RabbitMQ to versions 3.13.15, 4.0.20, 4.1.11, or 4.2.6 or later where this vulnerability is fixed. Ensure the management plugin and management.oauth_client_secret configuration are properly managed. No other mitigation is indicated by the vendor advisory.
Description
A vulnerability in RabbitMQ prior to versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6 allows disclosure of the OAuth 2 client secret via the obsolete GET /api/auth endpoint. This occurs when the management plugin and management.oauth_client_secret configuration are enabled, exposing sensitive credentials to unauthenticated callers. The issue is fixed in the specified versions.
References
- ubuntu.com/security/CVE-2026-57219 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-57219 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/98b1daf740237c85941e8addcbea6e74f4a2743c (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/commit/aa387c4451e7b674df3e3ba89df86a99d697cc7f (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/16083 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/pull/16086 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 (opens in a new tab)
- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-pj24-8j6m-vq9q (opens in a new tab)