Skip to main content
CVE-2026-54425VulnerabilityPublished Updated

Apache bRPC · Uncontrolled Recursion

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-54425· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.18.0 soon.

Data as of 30 Oct 2026, 17:02 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 1.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache bRPC and apache/brpc to 1.18.0.

Affected software

ProductAffectedFixed in
Apache bRPCapache/brpcAffected
  • <1.18.0
Fixed in
  • 1.18.0
GitHubapache/brpcpkg:github/apache/brpcOther threatsAffected
  • <1.18.0
Fixed in
  • 1.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache bRPC to version 1.18.0, which contains the official fix changing the HPACK decoder to iterative parsing. Applying the patch available at https://github.com/apache/brpc/pull/3343 also resolves the issue. No other mitigations are indicated.

Description

Apache bRPC versions before 1.18.0 contain an uncontrolled recursion vulnerability in the HTTP/2 HPACK decoder. Remote attackers can exploit this by sending a crafted HTTP/2 header block with many consecutive Dynamic Table Size Update entries, causing a denial of service via stack exhaustion. The issue arises because the decoder recursively processes each update without bounding recursion depth. The vulnerability is fixed in version 1.18.0 by changing the decoder to use iterative parsing.

References

Community reviews

Loading reviews…