CVE-2025-27221: URI Allows for Userinfo Leakage
Affects uriSource GCVE Database
Not known to be exploited · CVSS 3.2 Low : upgrade to 0.11.3 when convenient.
Data as of 30 Oct 2026, 16:04 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 3.2 |
|---|
- Patch
- Available – fixed in 0.11.3, 0.12.4, 0.13.2 +1
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsuri | Affected
| Fixed in
|
| RubyGemsuri | Affected
| Fixed in
|
| RubyGemsuri | Affected
| Fixed in
|
| RubyGemsuri | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the uri gem to version 0.11.3, 0.12.4, 0.13.2, 1.0.3 or later to remediate this vulnerability. No other mitigation actions are indicated as the fix is available and straightforward.
Description
The uri gem versions prior to 0.11.3, between 0.12.0 and 0.12.3, 0.13.0 to 0.13.1, and 1.0.0 to 1.0.2 allow userinfo leakage via the URI#join, URI#merge, and URI#+ methods. These methods retain userinfo such as user credentials even after the host component is replaced, potentially exposing sensitive information when generating URLs to malicious hosts. The issue is fixed in versions 0.11.3, 0.12.4, 0.13.2, and 1.0.3 or later.
References
- nvd.nist.gov/vuln/detail/CVE-2025-27221 (opens in a new tab)
- github.com/ruby/uri/pull/154 (opens in a new tab)
- github.com/ruby/uri/pull/155 (opens in a new tab)
- github.com/ruby/uri/pull/156 (opens in a new tab)
- github.com/ruby/uri/pull/157 (opens in a new tab)
- hackerone.com/reports/2957667 (opens in a new tab)
- github.com/ruby/uri (opens in a new tab)
- github.com/rubysec/ruby-advisory-db/blob/master/gems/uri/CVE-2025-27221.yml (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/03/msg00008.html (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/05/msg00015.html (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-27221 (opens in a new tab)
- ruby-lang.org/en/news/2025/02/26/security-advisories (opens in a new tab)