Skip to main content
CVE-2026-6653VulnerabilityPublished Updated

libxml2's xmlParseInternalSubset · Use After Free

Affects libxml2Source GCVE Database

0
Authoritative record:CVE-2026-6653· High 7.0

Public exploit available · CVSS 7.0 High · fixed in 2.9.13+dfsg-1ubuntu0.12 : patch libxml2 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.9.13+dfsg-1ubuntu0.12, 2.9.14+dfsg-1.3ubuntu3.8
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu libxml2 to 2.9.13+dfsg-1ubuntu0.12 (package) or 2.9.14+dfsg-1.3ubuntu3.8 (package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlibxml2pkg:deb/ubuntu/libxml2?arch=source&distro=nobleOther threatsAffected
  • <2.9.14+dfsg-1.3ubuntu3.8
Fixed in
  • 2.9.14+dfsg-1.3ubuntu3.8
Ubuntu 22.04 LTSlibxml2pkg:deb/ubuntu/libxml2?arch=source&distro=jammyOther threatsAffected
  • <2.9.13+dfsg-1ubuntu0.12
Fixed in
  • 2.9.13+dfsg-1ubuntu0.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Use After Free in libxml2's xmlParseInternalSubset from GNOME libxml2 version 2.9.11 to 2.11.0 allows a remote attacker to cause a denial-of-service via maliciously crafted XML input with improper entity resolution handling.

References

Community reviews

Loading reviews…