Skip to main content
VulnerabilityPublished

CVE-2026-6653: GNOME libxml2 · Use After Free

Affects GNOME libxml2Source CVE Database V5

0
Compare

Public exploit available · CVSS 7.0 High : upgrade to 2.11.0 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.11.0
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade GNOME libxml2 to 2.11.0.

Affected software

ProductAffectedFixed in
GNOMElibxml2Affected
  • >=2.9.11 <2.11.0
Fixed in
  • 2.11.0
Ubuntuubuntu/libxml2pkg:deb/ubuntu/libxml2Other threatsAffected
  • =2.9.11
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider applying workarounds such as disabling or restricting processing of untrusted XML input if feasible.

Description

Use After Free in libxml2's xmlParseInternalSubset from GNOME libxml2 version 2.9.11 to 2.11.0 allows a remote attacker to cause a denial-of-service via maliciously crafted XML input with improper entity resolution handling.

References

Community reviews

Loading reviews…