Skip to main content
CVE-2026-118550VulnerabilityPublished

Use of Web Browser Cache Containing Sensitive Information vulnerability in Drupal AI (Artificial Intelligence) allows

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118550· Medium

Not known to be exploited : upgrade to 1.5.2 or 1.4.11 when convenient.

Data as of 30 Oct 2026, 07:16 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 1.5.2, 1.4.11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade AI (Artificial Intelligence) and drupal/ai to 1.5.2 or 1.4.11.

Affected software

ProductAffectedFixed in
DrupalAI (Artificial Intelligence)Affected
  • >=1.5.0 <1.5.2
Fixed in
  • 1.5.2
DrupalAI (Artificial Intelligence)Affected
  • <1.4.11
Fixed in
  • 1.4.11
Packagistdrupal/aipkg:composer/drupal/aiOther threatsAffected
  • <1.4.11
  • >=1.5.0 <1.5.2
Fixed in
  • 1.4.11
  • 1.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, review and correct access control configurations to prevent sensitive data from being cached in browsers.

Description

A vulnerability in Drupal AI (Artificial Intelligence) allows sensitive information to be stored in the web browser cache due to incorrectly configured access control security levels. This affects versions from 0.0.0 to 1.4.11 and from 1.5.0 to 1.5.2. The issue could expose sensitive data through the browser cache if exploited.

References

Community reviews

Loading reviews…