Skip to main content
VulnerabilityPublished Updated

USN-8129-1: pyasn1 vulnerability

Affects pyasn1Source GCVE Database

0
Severity
Medium

Rated by Threat Radar

Patch
Available – fixed in 0.4.8-1ubuntu0.2, 0.4.8-4ubuntu0.2, 0.6.1-1ubuntu0.2

Data as of 16 Jul 2026, 14:26 UTC

What to do

Upgrade the Ubuntu pyasn1 to 0.4.8-1ubuntu0.2 (package) or 0.4.8-4ubuntu0.2 (package) or 0.6.1-1ubuntu0.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu:22.04:LTSpyasn1pkg:deb/ubuntu/pyasn1@0.4.8-1ubuntu0.2?arch=source&distro=jammyOther threatsAffected
  • <0.4.8-1ubuntu0.2
  • =0.4.8-1
  • =0.4.8-1ubuntu0.1
Fixed in
  • 0.4.8-1ubuntu0.2
Ubuntu:24.04:LTSpyasn1pkg:deb/ubuntu/pyasn1@0.4.8-4ubuntu0.2?arch=source&distro=nobleOther threatsAffected
  • <0.4.8-4ubuntu0.2
  • =0.4.8-4
  • =0.4.8-4ubuntu0.1
Fixed in
  • 0.4.8-4ubuntu0.2
Ubuntu:25.10pyasn1pkg:deb/ubuntu/pyasn1@0.6.1-1ubuntu0.2?arch=source&distro=questingOther threatsAffected
  • <0.6.1-1ubuntu0.2
  • =0.6.1-1
  • =0.6.1-1ubuntu0.1
Fixed in
  • 0.6.1-1ubuntu0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A vulnerability in pyasn1 was discovered where it incorrectly handles recursion during ASN.1 data decoding. This flaw can be exploited by an attacker to cause excessive resource consumption, resulting in a denial of service condition. Multiple specific versions of pyasn1 used in various Ubuntu releases are affected.

References

Community reviews

Loading reviews…