Skip to main content
VulnerabilityPublished Updated

CVE-2025-13327: uv has ZIP payload obfuscation through parsing differentials

Affects uvSource GCVE Database

0
Compare
Authoritative record:CVE-2025-13327· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.9.6 when convenient.

Data as of 30 Oct 2026, 01:17 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.16.3
Patch
Available – fixed in 0.9.6
CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade uv to 0.9.6.

Affected software

ProductAffectedFixed in
crates.iouvAffected
  • <0.9.6
Fixed in
  • 0.9.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in uv version 0.9.6. Users and administrators should update affected uv installations to version 0.9.6 or later to remediate this vulnerability. Refer to the Red Hat advisories RHSA-2026:91219, RHSA-2026:91232, and RHSA-2026:91236 for official patches and updates. No additional mitigation is required beyond applying the official fix.

Description

A vulnerability in the uv package allows code execution during package resolution or installation via specially crafted ZIP archives exploiting parsing differentials. This requires user interaction to install a malicious package. The flaw affects versions prior to 0.9.6 and has been fixed in version 0.9.6.

References

Community reviews

Loading reviews…