CVE-2026-55434: V2 · Coder vulnerable to denial of service via unbounded request body in AI Bridge provider endpoints
Affects github.com/coder/coder/v2Source GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.34.2 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.34.2, 2.33.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade github.com/coder/coder/v2 to 2.34.2; github.com/coder/coder/v2 to 2.33.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/coder/coder/v2 | Affected
| Fixed in
|
| Gogithub.com/coder/coder/v2 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in github.com/coder/coder/v2 versions v2.33.8 and later on the 2.33 release line, and v2.34.2 and later on the 2.34 release line. Users should upgrade to these versions to mitigate the vulnerability. No workarounds are available. Since this is not a cloud service, users must apply the patch themselves.
Description
### Summary AI Bridge provider handlers read request bodies with `io.ReadAll` without a maximum size so an authenticated user with AI Bridge access could send an arbitrarily large body and exhaust memory. > **Note:** Exploitation requires authenticated access to the AI Bridge endpoints and the impact is limited to availability (denial of service). ### Impact An authenticated member-level user could POST a very large or chunked body to an AI Bridge provider endpoint such as `/api/v2/aibridge/anthropic/v1/messages`, growing heap memory until the operating system terminates the process. Because AI Bridge runs in-process with `coderd`, this crashes the entire control plane, including the API, workspace coordinator and DERP relay. It requires an authenticated user and the AI Bridge feature enabled. ### Patches The fix applies `http.MaxBytesReader` or an equivalent cap before reading provider and session request bodies. The affected AI Bridge provider endpoints exist only on the v2.33 and v2.34 lines. Earlier release lines are not affected. The fix is available in the following releases: | Release line | Patched version | |---|---| | 2.34 | [v2.34.2](https://github.com/coder/coder/releases/tag/v2.34.2) | | 2.33 | [v2.33.8](https://github.com/coder/coder/releases/tag/v2.33.8) | ### Workarounds None. ### Resources - Fix: #26164 ### Credits Coder would like to thank Anthropic's Security Team (ANT-2026-22443) for independently disclosing this issue!
References
- github.com/coder/coder/security/advisories/GHSA-f5vp-w269-392g (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-55434 (opens in a new tab)
- github.com/coder/coder/pull/26164 (opens in a new tab)
- github.com/coder/coder (opens in a new tab)
- github.com/coder/coder/releases/tag/v2.33.8 (opens in a new tab)
- github.com/coder/coder/releases/tag/v2.34.2 (opens in a new tab)