Skip to main content
VulnerabilityPublished Updated

CVE-2026-7734: V4 · GoBGP has an Improper Resource Shutdown or Release

Affects github.com/osrg/gobgp/v4Source GCVE Database

0
Authoritative record:CVE-2026-7734· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.4.0 when convenient.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/osrg/gobgp/v4 to 4.4.0.

Affected software

ProductAffectedFixed in
Gogithub.com/osrg/gobgp/v4Affected
  • <4.4.0
Fixed in
  • 4.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A vulnerability has been found in osrg GoBGP up to 4.3.0. This impacts the function SRv6L3ServiceAttribute.DecodeFromBytes of the file pkg/packet/bgp/prefix_sid.go of the component SRv6 L3 Service. Such manipulation of the argument data leads to denial of service. The attack may be performed from remote. Upgrading to version 4.4.0 will fix this issue. The name of the patch is f9f7b55ec258e514be0264871fa645a2c3edad11. Users should upgrade the affected component.

References

Community reviews

Loading reviews…