CVE-2026-7734: osrg GoBGP · Denial of Service
Affects osrg GoBGPSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium · patch available : update osrg GoBGP when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| osrgGoBGP | Affected
| Fixed in– |
Gogithub.com/osrg/gobgppkg:golang/github.com/osrg/gobgpOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:osrg:gobgp:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading to GoBGP version 4.4.0. Since GoBGP is offered as a cloud service, the vendor manages remediation server-side. Users should verify with the vendor that their service instance has been updated to the patched version to mitigate this vulnerability.
Description
A vulnerability has been found in osrg GoBGP up to 4.3.0. This impacts the function SRv6L3ServiceAttribute.DecodeFromBytes of the file pkg/packet/bgp/prefix_sid.go of the component SRv6 L3 Service. Such manipulation of the argument data leads to denial of service. The attack may be performed from remote. Upgrading to version 4.4.0 will fix this issue. The name of the patch is f9f7b55ec258e514be0264871fa645a2c3edad11. You should upgrade the affected component.
References
- vuldb.com/vuln/360909 (opens in a new tab)
- vuldb.com/vuln/360909/cti (opens in a new tab)
- vuldb.com/submit/807581 (opens in a new tab)
- github.com/osrg/gobgp/commit/f9f7b55ec258e514be0264871fa645a2c3edad11 (opens in a new tab)
- github.com/osrg/gobgp/releases/tag/v4.4.0 (opens in a new tab)
- github.com/osrg/gobgp/ (opens in a new tab)