Skip to main content
VulnerabilityPublished Updated

CVE-2024-8365: Vault Leaks AppRole Client Tokens And Accessor in Audit Log

Affects vaultSource GCVE Database

0

Not known to be exploited : upgrade to 1.17.5 or 1.16.9 when convenient.

Data as of 26 Oct 2026, 12:29 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.17.5, 1.16.9

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vault to 1.17.5 or 1.16.9.

Affected software

ProductAffectedFixed in
Bitnamivaultpkg:bitnami/vaultOther threatsAffected
  • >=1.16.7 <1.16.9
  • >=1.17.3 <1.17.5
Fixed in
  • 1.16.9
  • 1.17.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in Vault Community Edition and Vault Enterprise versions 1.16.9 and 1.17.5. Users should upgrade affected versions to these fixed versions or later to remediate the vulnerability. No other mitigation is indicated by the vendor advisory.

Description

A vulnerability in Vault Community Edition and Vault Enterprise caused client tokens and token accessors to be logged in plaintext in audit logs due to removal of HMAC protection. This regression affects versions 1.16.7 through 1.16.8 and 1.17.3 through 1.17.4. The issue was fixed in versions 1.16.9 and 1.17.5. The vulnerability has medium severity and no known exploits in the wild.

References

Community reviews

Loading reviews…