Skip to main content
VulnerabilityPublished Updated

CVE-2024-2660: Vault TLS Cert Auth Method Did Not Correctly Validate OCSP Responses

Affects vaultSource GCVE Database

0

Not known to be exploited : upgrade to 1.16.0 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.16.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vault to 1.16.0.

Affected software

ProductAffectedFixed in
Bitnamivaultpkg:bitnami/vaultOther threatsAffected
  • >=1.14.0 <1.16.0
Fixed in
  • 1.16.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to Vault 1.16.0 or later, or Vault Enterprise 1.16.1, 1.15.7, or 1.14.11 to resolve the OCSP validation issue. Since a patch is available, remediation should be performed promptly to ensure proper OCSP response validation.

Description

Vault and Vault Enterprise versions 1.14.0 up to but not including 1.16.0 have a vulnerability in the TLS certificates authentication method where OCSP responses are not correctly validated when multiple OCSP sources are configured. This issue is fixed in Vault 1.16.0 and Vault Enterprise versions 1.16.1, 1.15.7, and 1.14.11. The vulnerability has a medium severity rating and no known exploits in the wild have been reported.

References

Community reviews

Loading reviews…