Vikunja before 2.7.1 contains a denial of service vulnerability that allows authenticated users to exhaust API process
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2.7.1 soon.
Data as of 8 Nov 2026, 06:49 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade vikunja to 2.7.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| go-vikunjavikunja | Affected
| Fixed in
|
Govikunjapkg:golang/vikunjaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Vikunja version 2.7.1. Users should upgrade to version 2.7.1 or later to remediate this vulnerability. No other mitigation or workaround is indicated.
Description
Vikunja versions prior to 2.7.1 have a denial of service vulnerability that allows authenticated users to exhaust API process memory by uploading large WeKan or vikunja-file imports without item-count limits. Attackers can submit a large (~22 MB) WeKan JSON file containing hundreds of thousands of cards or duplicate IDs to the migration endpoint, causing an out-of-memory condition and crashing the instance.