Vikunja veans before 2.7.1 contains a credential exposure vulnerability that allows malicious repository authors to
Source GCVE Database
Not known to be exploited · CVSS 6.0 Medium : upgrade to 2.7.1 when convenient.
Data as of 8 Nov 2026, 07:02 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.0 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.9 |
- Patch
- Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade vikunja to 2.7.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| go-vikunjavikunja | Affected
| Fixed in
|
Govikunjapkg:golang/vikunjaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid running veans in untrusted checkouts or ensure that .veans.yml files come from trusted sources to prevent credential leakage.
Description
Vikunja veans versions before 2.7.1 have a credential exposure vulnerability. Malicious repository authors can specify an attacker-controlled server in the .veans.yml configuration file. When veans runs in an untrusted checkout, it may send sensitive credentials such as the VEANS_TOKEN bearer token, login passwords, TOTP codes, and other tokens to the attacker-controlled server. This exposure grants attackers access to the victim's Vikunja account.